Ubuntu16.10安装Pytorch

如果你的系统是Linux和OS X,Pytorch的安装很简单,直接去官方网站找合适的下载包就可以了。可能之前十分呆萌的没有看清楚,安装好了torch7科学计算库,哈哈哈。 torch7安装教程。Pytorch依赖库的安装安装pytorch需要两个依赖库,pyyaml和numpy。sudosudo进行Pytorch的安装笔者的是python 2.7 linux 没有安装cuda:sudo pip

如果你的系统是Linux和OS X,Pytorch的安装很简单,直接去官方网站找合适的下载包就可以了。

可能之前十分呆萌的没有看清楚,安装好了torch7科学计算库,哈哈哈。
安装torch7的教程在这里:torch7安装教程

Pytorch依赖库的安装

安装pytorch需要两个依赖库,pyyaml和numpy。

sudo pip install pyyaml
sudo pip install numpy

进行Pytorch的安装

笔者的是python 2.7 linux 没有安装cuda:

sudo pip install http://download.pytorch.org/whl/cu75/torch-0.2.0.post3-cp27-cp27mu-manylinux1_x86_64.whl
sudo pip install torchvision
# if the above command does not work, then you have python 2.7 UCS2, use this command
pip install http://download.pytorch.org/whl/cu75/torch-0.2.0.post3-cp27-cp27m-manylinux1_x86_64.whl

安装时Terminal的提示:

Processing ./torch-0.2.0.post3-cp27-cp27mu-manylinux1_x86_64.whl
Requirement already satisfied: pyyaml in /usr/local/lib/python2.7/dist-packages (from torch==0.2.0.post3)
Requirement already satisfied: numpy in /usr/local/lib/python2.7/dist-packages (from torch==0.2.0.post3)
Installing collected packages: torch

在运行中碰到的问题,解决办法是更新numpy。
问题描述:

ImportError: numpy.core.multiarray failed to import

解决方法:

sudo pip install -U numpy


作者:KKokoZeng
原文链接:https://blog.csdn.net/kokozeng1995/article/details/78534921

  • 发表于 2019-11-05 20:13
  • 阅读 ( 46 )
  • 分类:pytorch

0 条评论

请先 登录 后评论
不写代码的码农
KKokoZeng_csdn

0 篇文章

作家榜 »

  1. AI君 10 文章
  2. Tzung-Wen Liau 0 文章
  3. blairan 0 文章
  4. rookie 0 文章
  5. 陈凯 0 文章
  6. huanxue 0 文章
  7. admin 0 文章
  8. Lzs1998_csdn 0 文章